$re = '/(?<operator> [A-Z]+ (?=([^\"]*\"[^\"]*\")*[^\"]*$))/m';
$str = 'method(ARG,"No AND Yes OR other") OR (method(ARG,ARG) AND method(method(ARG),ARG))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);