import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:leng|wid|dep)th\\h+\\d+(?:\\.\\d+)?(?:\\h+cm)?\\b";
final String string = "length 10 cm width 2 cm depth 0.5 cm / length 10 cm width 2 depth 0.5 cm\n";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}