package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+,\d{2}$`)
var str = `10,00
10\ddd,00
10\ddd\ddd,00
1000,00
123456,00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}