const regex = new RegExp('(?=^.{8,22}$)(?=(.*\\d){2})(?=(.*[A-Z]))^[a-zA-Z].*$', 'gm')
const str = `asasas4aS5as.
asasaaa4aS5a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}