# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((((r?d_(MON|TUE|WED|THU|FRI|SAT|SUN))_?([0][1-5])?(([-+])([0-9]{3}))?)|(r?d_[0-9]{3}))|rd|((r?m_((JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)|([0][1-9]|[1][0-2])))_?((d[0-9]{2})|(MON|TUE|WED|THU|FRI|SAT|SUN)_?([0][1-5])?)))$"
test_str = ("d_MON_02\n"
"rd\n"
"rd_029\n"
"rd_MON\n"
"rd_MON_01\n"
"rd_MON_01+007\n"
"rd_WED_03-007\n"
"rm_JAN_d29\n"
"rm_01_d29\n"
"rm_JAN_MON02\n"
"m_JAN_MON01\n"
"rm_JAN_MON\n\n"
"one off second Monday\n"
"repeat daily\n"
"repead daily on the 29th\n"
"repead daily on Monday\n"
"repeat first Monday\n"
"repeat second Monday with offset of 7 days\n"
"repeat second Wednesday with negative offset of 7 days\n"
"repeat on 29th of January with 3 characters month name format\n"
"repeat on 29th of January with 2 digit numbering month format\n"
"repeat second Monday of January\n"
"one off first Monday of January\n"
"repeat all Mondays in January")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.