package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),[\s]*,`)
var str = `[
{ id: "sdfs"},
{ id: "zxv"},,
{ id: "wer"}
]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}