re = /\/?(\w+)\??(\w+)?/m
str = 'mystring
/mystring
mystring?test
/mystring?test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end