const regex = new RegExp('background-image: url\\(\\"\\/\\/external-content\\.duckduckgo\\.com\\/iu\\/\\?u=(.*)&f=1&h=110\\"\\);', 'g')
const str = `background-image: url("//external-content.duckduckgo.com/iu/?u=https%3A%2F%2Fimage.cnbcfm.com%2Fapi%2Fv1%2Fimage%2F106261274-1574442599483rtx7a0ls.jpg%3Fv%3D1574452686&f=1&h=110");
background-image: url("//external-content.duckduckgo.com/iu/?u=https%3A%2F%2Fimg-s-msn-com.akamaized.net%2Ftenant%2Famp%2Fentityid%2FAAMcjDx.img%3Fh%3D630%26w%3D1200%26m%3D6%26q%3D60%26o%3Dt%26l%3Df%26f%3Djpg%26x%3D2091%26y%3D602&f=1&h=110");
background-image: url("//external-content.duckduckgo.com/iu/?u=https%3A%2F%2Fs.yimg.com%2Fny%2Fapi%2Fres%2F1.2%2FJSwEklq4.Wb9rSN4Jos8Pw--%2FYXBwaWQ9aGlnaGxhbmRlcjt3PTIwMDA7aD0xNTAw%2Fhttps%3A%2F%2Fs.yimg.com%2Fuu%2Fapi%2Fres%2F1.2%2FqLOFL2gnGPZmvsHf_FnjvQ--~B%2FaD0yMzIxO3c9MzA5NTthcHBpZD15dGFjaHlvbg--%2Fhttps%3A%2F%2Fmedia.zenfs.com%2Fen%2Fbusiness_insider_articles_888%2F9d51192cb64af28f340c46700be07207&f=1&h=110");
background-image: url("//external-content.duckduckgo.com/iu/?u=https%3A%2F%2Fi.insider.com%2F601816796dfbe10018e0106a%3Fwidth%3D1200%26format%3Djpeg&f=1&h=110");
background-image: url("//external-content.duckduckgo.com/iu/?u=https%3A%2F%2Fa57.foxnews.com%2Fstatic.foxbusiness.com%2Ffoxbusiness.com%2Fcontent%2Fuploads%2F2019%2F11%2F0%2F0%2FAP19326175844301-e1574611302337.jpg%3Fve%3D1%26tl%3D1&f=1&h=110");
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}