$re = '/sprintf_w\(
(
(?: " (?: [^"\\\\] | \\\\. )*+ "
| \' (?: [^\'\\\\] | \\\\. )*+ \'
| [^"\',()]+
| \( (?1) \)
)*+
)/xs';
$str = 'fdf sprintf_w($af, $a, $b) sprintf_w("dff fg", $a, $b)
sprintf_w("dff, (fg) (fs)", $a, $b) sprintf_w("dff, fg", $a, $b)
sprintf_w(\'dff, "fg"\', $a) fdf 45
sprintf_w( lol("dff") , $a)
';
$subst = "_w($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;