$re = '/\$\{([^{}]+)\}/m';
$str = '${abc.xzy}/demo/${ttt.bbb}\\ntest${kkk.mmm}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);