$re = '/(?:^.*\n)*(?=^01_200_A.B.C.\\\\_Two_Room$)/m';
$str = '00_000_A.B.C.\\_One_Room
Schrute_Dwight
Halpert_Jim
Scott_Michael
00_000_A.B.C.\\_One_Room
Schrute_Dwight
Halpert_Jim
Scott_Michael
01_200_A.B.C.\\_Two_Room
Schrute_Dwight
Halpert_Jim
Scott_Michael';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);