# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)a\.b \{.*c\n\}\n"
test_str = ("foo.bar {\n"
" always same bus\n"
"}\n"
"1.2 {\n"
" always same 3\n"
"}\n"
"a.b {\n"
" always same c\n"
"}\n"
"i.ii {\n"
" always same iii\n"
"}\n"
"b.2 {\n"
" always same c\n"
"}\n"
"1.2 {\n"
" always same b\n"
"}")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.