import Foundation
let pattern = ###"(?<=\|)(\d{4},[\d,]+)\n (\|.+\|)([\d,]+)(?=\n##@@)"###
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
|GUIA DE RECURSO DE GLOSAS |2 - Nº Guia no Prestador |0
|1 - Registro ANS |3 - Nome da Operadora |4 - Objeto do Recurso |5 - Número de Guia de Recurso de Glosas Atribuído pela Operadora
|346659 |CASSI - Caixa de Assistência dos Funcionários do Banco do Brasil |2 |3647035
|Dados do Contratado
|6 - Código na Operadora |7 - Nome do Contratado
|2049988 |SAO LUCAS RIBEIRANIA LTDA
|Dados do recurso do protocolo
|8 - Número do Lote |9 - Número do Protocolo |10 - Código da Glosa do Protocolo |11 - Justificativa (no caso de recurso integral do protocolo) |12 - Acatado
|70743253 |70743253 |S
|Dados do recurso da guia
|13 - Número da guia no prestador |14 - Número da guia atribuido pela operadora |15 - Senha
|9998011 |211807712 |20457829
|16 - Código da glosa da guia |17 - Justificativa (no caso de recurso integral da guia) |18 - Acatado
|S
|Dados do recurso do procedimento ou item assistencial
|19 - Data de realização |20 - Data final período |21 - Tabela |22 - Procedimento/Item assistencial |23 - Descrição |24 - Grau de |25 - Código da glosa
|Participação
|26 - Valor Recursado |27 - Justificativa do Prestador
|28 - Valor Acatado |29 - Justificativa da Operadora
|15/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |48,68
|22,48 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|15/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|15/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|15/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |36,51
|16,86 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|15/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|15/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|16/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|16/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|16/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |48,68
|22,48 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|10 |16/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|11 |16/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|12 |16/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|13 |17/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|14 |17/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|15 |17/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|16 |17/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|17 |17/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|18 |17/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|19 |17/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|20 |18/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|21 |18/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|22 |18/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|23 |18/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|24 |18/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente
|25 |18/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|26 |18/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|27 |19/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006,2006,2006,20
|06
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|28 |19/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|29 |19/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|30 |19/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|31 |19/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|32 |19/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|33 |20/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |36,51
|16,86 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|34 |20/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|35 |20/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|36 |20/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |73,02
|33,72 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|37 |20/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|assistência ventilatória |006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|38 |24/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|39 |24/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |48,68
|22,48 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|40 |24/01/2020 |19 |70705267 |BD Posiflush Pre-Filled Normal Saline Flush Syringe - Seringa preenchi |2006,2006,2006,2006,2
|006,2006
##@@ |24,34
|11,24 |Item abonado conforme negociação em contrato - Item abonado conforme negociação contratual vigente.
|30 - Valor Total Recursado (R$) |31 - Valor Total Acatado (R$)
|1.752,48 |809,28
|32 - Data do Recurso |33 - Assinatura do Contratado |34 - Data da Assinatura da Operadora |35 - Assinatura da Operadora
|16/10/2021
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)