#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([a-zA-Z]*)(ne|eb|ar|(?<!nom)br|il|ay|yo|un|nio|ul|lio|go|sto|ep|mbr|ct|ubr|ov|ic|en|ero|fe(?!cha)|ma|ab|ju|jo|ja|jn|ag|se|oc|nov|dic)([a-zA-Z]*)[- \/.,\n|i]{1,3}(0[1-9]|[12][0-9]|3[01]|[1-9]|i|o[1-9zi]|i[1-9zo])[- \/.,\n|i]{1,3}[2z][0o]\d{0,2}\b"
Local $sString = "Feb zi /" & @CRLF & _
"zozo" & @CRLF & _
"10" & @CRLF & _
"12030" & @CRLF & _
"nombre" & @CRLF & _
"fecha" & @CRLF & _
"01 / 2020" & @CRLF & _
"yl-20-2.020" & @CRLF & _
"FECHA: 2020-06-04 08:57:29" & @CRLF & _
"FECHA: 12 106 120" & @CRLF & _
"GARAG" & @CRLF & _
"marzo" & @CRLF & _
"15/2000" & @CRLF & _
"mayo 15/20" & @CRLF & _
"jul 1/20" & @CRLF & _
"Junio 17/20" & @CRLF & _
"S:" & @CRLF & _
"BUN" & @CRLF & _
"Centro Médico" & @CRLF & _
"FECHA:" & @CRLF & _
"05 06 - 2020" & @CRLF & _
"Warta carolina onerrez" & @CRLF & _
"Nombre:" & @CRLF & _
"1/6/200" & @CRLF & _
"ONDY Soklo" & @CRLF & _
"Fecha:" & @CRLF & _
"nFECHA: 2020-06-04 08:57:29" & @CRLF & _
"FECHA: 2020-06-04 08:57:2" & @CRLF & _
"Bogotá, 08/jun./2020" & @CRLF & _
"FECHA 11/06/2020" & @CRLF & _
"nBOGOTAOC - 10/06/2020" & @CRLF & _
"1/6/200" & @CRLF & _
"ONDY Soklo" & @CRLF & _
"Fecha:" & @CRLF & _
"echa 24-unio 12020" & @CRLF & _
"Fecha:" & @CRLF & _
"17.06.2020" & @CRLF & _
"FECHA:" & @CRLF & _
"2020" & @CRLF & _
"24 Junio" & @CRLF & _
"Fecha: 12 - vw" & @CRLF & _
"FECHA" & @CRLF & _
"VUNIO 18" & @CRLF & _
"18/2010" & @CRLF & _
"Jula 2020" & @CRLF & _
"FECHA:" & @CRLF & _
"05 06 - 2020" & @CRLF & _
"10 /m/ 200" & @CRLF & _
"2020" & @CRLF & _
"" & @CRLF & _
"FECHA\nTo\nol06" & @CRLF & _
"\n18106 12020\n" & @CRLF & _
"204\nFecha:" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")