$re = '/(?P<firstName>^\w+)\s(?P<middleAndLast>.+)/m';
$str = 'John Allen Smith
Alex Bradford Johnson
Fredrick Douglas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);