import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{1,2}(?:\\.\\d{1,2}\\.|\\h+\\p{Lu}\\p{Ll}+\\h+)(?:\\d\\d|\\d{4})\\b";
final String string = "01.01.2022\n"
+ "1.01.2022\n"
+ "1.1.2022\n"
+ "1.1.22\n"
+ "...\n"
+ "Now I have a date format like this:\n\n"
+ "25 März 2023\n"
+ "or\n"
+ "25 March 2023";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}