$re = '/(<\s*\d*\.?\d+)/m';
$str = '< 0.071U ug/L';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);