re = /F.*(?<=ies\s)|F.*\n\S+/m
str = 'This is a Fai - airies example
This is a Fa- 8 -
iries example
Another Fai-ries story'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end