package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\+611800)\d{6}|^(\+61)\d{9}`)
var str = `+61180012345
+61123456789
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}