$re = '/(?<!_)_(?!_)/m';
$str = 'he__llo
hel_o';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;