import re
regex = re.compile(r"^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?::(\d|[1-9]\d{1,3}|[1-5]\d{4}|6[0-4]\d{3}|65[0-4]\d{2}|655[0-2]\d|6553[0-5]))?$")
test_str = ("188.80.74.150\n"
"169.157.62.216\n"
"81.46.96.107\n"
"44.119.14.70\n"
"161.17.234.246\n"
"205.62.196.10\n"
"213.64.103.147\n"
"78.199.17.216:34\n"
"78.165.189.94:0\n"
"205.62.196.10:5656\n"
"57.112.40.255:65536")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")