const regex = /[[:alpha:]]{6}[0-9]{2}[abcdehlmprst]{1}[[:digit:]]{2}[a-z]{1}[0-9]{3}[[:alpha:]]{1}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[[:alpha:]]{6}[0-9]{2}[abcdehlmprst]{1}[[:digit:]]{2}[a-z]{1}[0-9]{3}[[:alpha:]]{1}', 'gmi')
const str = `6x7 456 78993 45528 8382 837372 82 128 8282 82 828282 28 8282635372892 838
Lorem ipsum dolor 335-5555555 sit amet, consectetur adipisci5555555555 elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur. 3835555555 Quis aute iure reprehenderit in voluptate 555/555555velit esse cillum dolore eu fugiat nulla pariatur. 43434734 343 3 464 56 5 65 6 5 757 676
Excepteur sint obcaecat cupiditat non RSSNDR74D04A271P proident, sunt in culpa qui officia deserunt mollit anim id est laborum. Lorem ipsum dolor sit amet, consec 234 546 367 2789 tetur adipisci elit,347/5555555 sed eiusm 565437 od tempor incidunt ut labore et dolore magna aliqua. Ut enim ad minim
Ut enim ad minim 555-555555veniam, quis rssndr74d04a271u nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur. Quis aute iure r328 5555555 eprehenderit in volup6767676767 6767676767tate 555 555555velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint obcae67676767676767676cat rssndr74D04A271U cupidita34567893 t non proident, sunt in culpa qui officia deserunt mollit anim id est laborum. 388.555555 Lorem rSsndr74d04a271u ipsum dolor sit amet, consectetur adipisci elit, sed eiusmod tempor incidunt ut labore et dolore magna a6767676767 32252525 353535 5353535liqua. Ut enim ad minim`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}