$re = '/^(?=\S{8})[a-zA-Z]\w*(?:\.\w+)*(?:@\w+\.\w{2,4})?$/m';
$str = 'user@user.com
adminuser1
user.user@user.com
Invalid:
user@user.user.com
1adminuser1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);