$re = '/[^\P{L}A-Za-z]+/u';
$str = 'कबमन 456 abc foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);