const regex = /^((0[13578]|1[02])[\/.]31[\/.](19|20)[0-9]{2})|((01|0[3-9]|1[1-2])[\/.](29|30)[\/.](19|20)[0-9]{2})|((0[1-9]|1[0-2])[\/.](0[1-9]|1[0-9]|2[0-8])[\/.](19|20)[0-9]{2})|((02)[\/.]29[\/.](((19|20)(04|08|[2468][048]|[13579][26]))|2000))$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((0[13578]|1[02])[\\\/.]31[\\\/.](19|20)[0-9]{2})|((01|0[3-9]|1[1-2])[\\\/.](29|30)[\\\/.](19|20)[0-9]{2})|((0[1-9]|1[0-2])[\\\/.](0[1-9]|1[0-9]|2[0-8])[\\\/.](19|20)[0-9]{2})|((02)[\\\/.]29[\\\/.](((19|20)(04|08|[2468][048]|[13579][26]))|2000))$', 'g')
const str = `01/30/2016asdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}