import re
regex = re.compile(r"^([0-9]{1,3}\.){3}[0-9]{1,3}(\/([0-9]|[1-2][0-9]|3[0-2]))?$", flags=re.MULTILINE)
test_str = ("192.168.0.1\n"
"192.168.0.1/\n"
"192.168.0.1/0\n"
"192.168.0.1/1\n"
"192.168.0.1/2\n"
"192.168.0.1/3\n"
"192.168.0.1/4\n"
"192.168.0.1/5\n"
"192.168.0.1/6\n"
"192.168.0.1/7\n"
"192.168.0.1/8\n"
"192.168.0.1/9\n"
"192.168.0.1/10\n"
"192.168.0.1/11\n"
"192.168.0.1/12\n"
"192.168.0.1/13\n"
"192.168.0.1/14\n"
"192.168.0.1/15\n"
"192.168.0.1/16\n"
"192.168.0.1/17\n"
"192.168.0.1/18\n"
"192.168.0.1/19\n"
"192.168.0.1/20\n"
"192.168.0.1/21\n"
"192.168.0.1/22\n"
"192.168.0.1/23\n"
"192.168.0.1/24\n"
"192.168.0.1/25\n"
"192.168.0.1/26\n"
"192.168.0.1/27\n"
"192.168.0.1/28\n"
"192.168.0.1/29\n"
"192.168.0.1/30\n"
"192.168.0.1/31\n"
"192.168.0.1/32\n"
"192.168.0.1/33\n"
"192.168.0.1/34\n"
"192.168.0.1/asd\n"
"192.168.0.1/01\n"
"192.168.0.1/00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")