using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?=[^][]*\])";
string input = @"Test bla bla [us_image_slider ids=""6207,6204,6203,6199,6484,6470"" nav=""thumbs"" img_size=""us_img_size_2""] some numbers 232323 [img=""344""] and [daas 23344 2333]2323 ( hello 233 )";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}