re = /(uni[0-9A-F]{4}.)(bgr)/m
str = 'afii10038.bgr uni0424.bgr
afii10077.bgr uni043B.bgr
afii10067.bgr uni0432.bgr
afii10049.ss03 uni042F.ss03
afii10072.bgr.ss03 uni0436.bgr.ss03
afii10072.ss03 uni0436.ss03
afii10148.ss01 uni0474.ss01
afii10061.ss01.ss03 uni040C.ss01.ss03
afii10108.ss11 uni045B.ss11
afii10076.bgr.ss03 uni043A.bgr.ss03
afii10089.ss11 uni0447.ss11
afii10069.ss11 uni0434.ss11
afii10076.ss03 uni043A.ss03
'
subst = '\\1cyr_BGR'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result