$re = '/^(?!.*\d{11}).*$/m';
$str = 'abcde1234567890acd
abcde12345678901acd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);