$re = '/X\s*([^\sX](?:[^X]*[^\sX])?)/m';
$str = 'X
aaaa
X
bbbb
X
cccc
XX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);