$re = '/\w+(?=\s\s)/';
$str = '18890 8th Ave NE
Poulsbo, WA 98370-8770
United States';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);