const regex = new RegExp('device-group\\S(?P<device_group> \\S+)\\s|with |succeeded', 'gm')
const str = `1,2022/09/22 10:01:40,013101004778,SYSTEM,general,2561,2022/09/22 10:01:40,,general,,0,0,general,informational,"Panorama push to device:013101010578 for device-group: Durham_IPV6_INET_SVCS succeeded. JobId=2480530"
1,2022/09/22 10:01:40,013101004778,SYSTEM,general,2561,2022/09/22 10:01:40,,general,,0,0,general,informational,"Panorama push to device:007257000068919 for device-group: Azure-China-Internet-North succeeded. JobId=2480524"
1,2022/09/22 10:01:40,013101004778,SYSTEM,general,2561,2022/09/22 10:01:40,,general,,0,0,general,informational,"Panorama push to device:016401009013 for device-group: Austin_Experience_Lounge succeeded. JobId=2480530"
1,2022/09/22 10:01:40,013101004778,SYSTEM,general,2561,2022/09/22 10:01:40,,general,,0,0,general,informational,"Panorama push device-group APCC1_Core_Controller with merge-with-candidate-cfg flags set.JobId=60265.User=Panorama-admjeen_yeong_choong. Dequeue time=2022/09/22 10:01:39. DG version: APCC1_Core_Controller: 11854. ",7136408369296042839,0x8000000000000000,0,0,0,0,,apcc1pafwcc01,0,0,2022-09-22T10:01:40.203+00:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}