package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)day(\d+)(.*)`)
var str = `day1mt
day21h
day321hist
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}