package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?|([a-zA-Z0-9]+)[({[«]([a-zA-Z\s]+)[)}\]»]|[({[«]([a-zA-Z\s]+)[)}\]»]([a-zA-Z0-9]+))`)
var str = `// i want to mark for single brackets examples below other heighlight pattren not disturb.please
(weather // i want to mark this word
weather) // i want to mark this word
(weather is good // i want to mark this word
weather is good) // i want to mark this word
weathe)r
wea(ther
and same for other brackets {,[,«
{weather // i want to mark this word
weather} // i want to mark this word
{weather is good // i want to mark this word
weather is good} // i want to mark this word
weathe}r // i want to mark this word
weathe{r // i want to mark this word
[weather // i want to mark this word
weather] // i want to mark this word
[weather is good // i want to mark this word
weather is good] // i want to mark this word
weathe]r // i want to mark this word
weathe[r // i want to mark this word
«weather // i want to mark this word
weather} // i want to mark this word
«weather is good // i want to mark this word
weather is good» // i want to mark this word
weathe»r // i want to mark this word
weathe»r // i want to mark this word
(Weather) is good. // not need to mark this beacuase this word correct word
Weath(er) is good. // mark
Weath(er is good). // mark
Weather (is) (good).
My name is Rah(eel) // mark
Best pro(duct) // mark
(Weather is good) // not need to mark this beacuase this word konown word
we(ather)
(weath)er is good. // mark
(weath)er // mark
weather(is fine)
weather is good
{weather is good} //not need to mark correct
weat{er is good} // mark
we{ather} is fine // mark
{weathe}r is fine // i want to mark this word
{weather is fin}e // i want to mark this word
[weather is good] //not need to mark correct
weat[her is good] // mark
we[ather] is fine // mark
[weathe]r is fine // mark
[weather is f]ine // mark
we[ather] is fine // mark
«weather is good» //not need to mark
weat«her is good» // mark
we«ather» is fine // mark
«weat»her is fine // mark
«weather is fi»ne // mark
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}