re = /\(\*(([^\(*]|\(($|[^*])|\*($|[^\(]))*)\*\)/
str = '(* This is a comment you will forget -- *)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end