$re = '/ COMM ([\d]+,[\d]+) /m';
$str = 'Situazione al 18.12.2024 ore 16:57:10 del Conto Corrente IT 74 G 02008 12609 000100129899 - ILS ITALIAN LINUX SOCIETY
Saldo Euro 14,601.69 a CREDITO
Ultimi movimenti registrati
Data;Valuta;Descrizione;Euro;Caus.
16/12/2024;16/12/2024;DISPOSIZIONE DI BONIFICO BONIFICO SEPA A ROMA2LUG - TOR VERGATA LINUX USERS PER Rimborso spese 68 COMM 0,74 SPESE 0,00 TRN 1101243500012002;-1,065.73;208
11/12/2024;11/12/2024;BONIFICO A VOSTRO FAVORE BONIFICO SEPA DA XXXX PER Quota annuale prima iscrizione XXX TRN YYY;25.00;048';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);