$re = '/\b\d+(?=.*\bsomething\b)/s';
$str = '20
30
abc
40
def
something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);