$re = '/\sWHERE\s+(.*?)(?:\s+(?:GROUP\s+BY|HAVING|ORDER\s+BY|ASC|DESC|LIMIT)\b|\s*$)/mi';
$str = 'SELECT * FROM users WHERE id=1 or id=2
SELECT * FROM users WHERE id=1 or id=2 GROUP BY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);