$re = '/(jan|feb|mar)[a-z]*[0-9]/i';
$str = 'January1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);