package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\|[^|]+?)\|([^|]*?@.+?\|)`)
var str = `| Jo|hn@dmail.com|
| |Chris@dmail.com|
| RebeccaFML|@dmail.com|
| BozoSMH|@yahow.com|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}