$re = '/(?<=\.)\d{2}$/m';
$str = '192.168.23.84
192.168.897.34
192.168.43.345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);