const regex = new RegExp('^(?P<protocol>https?|git|ssh|rsync)\\://(?:(?P<user>.+)@)*(?P<host>[a-z0-9_.-]*)[:/]*(?P<port>[\\d]+){0,1}(?P<pathname>\\/((?P<owner>.+)\\/)?((?P<repository>.+?)(\\.git|\\/)?)?)$', 'smi')
const str = `http://username@fontes.domain.com.br:7990/scm/site/name-of-repo.git`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}