import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)_((?:x\\d{1,4}|\\d{1,4}x)(?:\\d{1,4})?(?=\\+|\\.).*)\\.(.+)";
final String string = "/banner/tenis-15088083003831_x1000+crop_center+q_80+f_999+jpg.png\n\n"
+ "/banner/tenis-15088083003831_2200x9220+crop_center+q_80+F_999+jpg.png\n\n"
+ "/banner/tenis-1508_8083003831_200x+crop_center+q_80+f_999+jpg.png\n\n"
+ "/banner/tenis-15088_x21230_83003831_200x.png\n\n"
+ "/banner/tenis-15088083003831_200x100.png\n"
+ "/banner/tenis-15088083003831_x1000.png\n\n"
+ "http://cdn.dooca.com.br/melbenett.com.br/banner/tenis-1508808_3003831.png\n\n"
+ "http://cdn.dooca.com.br/melbenett.com.br/banner/tenis-1508808_123123x12312331.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}