$re = '`^\([1-9]\d{2}\)\s\d{3}-\d{4}$`';
$str = '(111) 999-9999';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);