re = /User\:([\r\n]*)(?<UserName>\S+)/
str = '...
User:
employeename@company.com
....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end