# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((([a-zA-Z]+)(\s)*(:))){1}(\s)*(((?:[\[])?(?:[\"])?((.)*)(?:[\"])?(?:[\]]?))?)?([,]?)"
test_str = ("{\n"
" id: \"00000000-0000-0000-0000-000000000000\",\n"
" numericId: 0,\n"
" accountId: \"00000000-0000-0000-0000-000000000000\",\n"
" accountCode: \"\",\n"
" groups: [\"group1\"],\n"
" isTest: true,\n"
" ftpInfo: {\n"
" host: \"127.0.0.1\",\n"
" port: 21,\n"
" homeDirectory: \"/\",\n"
" fileMask: \"*.txt\",\n"
" username: \"\",\n"
" password: \"\",\n"
" isPassive: true,\n"
" isBinary: true\n"
" },\n"
" contactName: \"\",\n"
" contactEmailAddress: \"\",\n"
" createdOn: \"1900-01-01T00:00:00\",\n"
" modifiedOn: \"1900-01-01T00:00:00\"\n"
"}")
subst = "\"$3\": $7$11"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.