package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*[^\s,?]{0,4}(?:\s*,\s*[^\s,?]{0,4})*\s*$`)
var str = `Hi, hows`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}