$re = '/(?=123)\d{10}/';
$str = '1234567890
123456789
12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);