import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<==)([%]?\\w+[-@.]?)+)|([\\w]+[-%~&]*[\\d]+[\\w]+/?[-%~&]?)+";
final String string = "https://sales.dell.com/customer/details/id/11~82373834\n\n"
+ "https://www.dell.com/salesapp/quote/internal/us/en/3000127988306/1%3fsccmessageid%3d76e45b07-61a9-4e1a-b3d4-086736cc7b1b&skipquotevalidation%3dfalse\n\n"
+ "https://sales.dell.com/products/configure/line/g0bggab-0kg13lz1eqb33g\n\n"
+ "https://sales.dell.com/customer/details/customernumber/147973836?companynumber=20&shippingid=wd9sv2jmwk27e2wxkgyy2q&installat=true&buid=11\n\n"
+ "https://sales.dell.com/salesapp/checkout/internal/us/en/compliance-notification/fwta3fm6xu6ua6qys5xozq?sccmessageid=98ab9dab-2877-4ead-9ea9-1746a664c778\n\n"
+ "https://sales.dell.com/salesapp/order/ca/en/2009403933624?bu=707\n\n"
+ "https://sales.dell.com/customer/details/customernumber/530028073281?companynumber=18&shippingid=xshqt90gbuwhqtr-lfxtxa&shipto=true\n\n";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}